Error message: "IKERNEL.EXE Could Not be Launched"

Author Scott M on February 15, 2012 | Print | Bookmark
Last updated on April 6, 2012

Document relates to: Laplink Gold (All versions)

 

SUMMARY

When I try to install Laplink, I receive this error message: "The InstallShield engine IKERNEL.EXE could not be launched. Error loading type library/dll". What can I do?

 

CAUSE

InstallShield displays this message when it cannot run. There are several possible causes.

 

SOLUTION

For computers running Windows 95, 98 and Millennium

  • If another InstallShield setup just finished, the engine (IKERNEL.EXE) stays in memory for a few seconds at the end of an install. Wait a few seconds and try again.

  • Press Ctrl/Alt/Del, and look for IKERNEL.EXE on the Close Program List. If no setup program is currently running, highlight IKERNEL.EXE and click End Task. Try the setup again.

  • Use Windows Explorer, and remove all files from the C:\Temp folder.

  • Use Windows Explorer and open Program Files\Common Files\InstallShield. Remove theEngine folder and then rerun the setup.

  • Core Windows files may be missing or corrupted. Reinstall the latest Internet Explorer.

  • Core Windows file STDOLE.TLB is missing. Copy this file from another computer running the same version of Windows.

  • If the computer runs Windows 98, install DCOM98.EXE from the following site:http://www.microsoft.com/com/dcom/dcom98/download.asp.


For computers running Windows NT, 2000 and XP

  • You have insufficient permissions with your current Windows logon. You must haveadministrative permissions to run an InstallShield setup program. Check with your network administrator or Help Desk if you need to change your permissions.

  • If another InstallShield setup just finished, the engine (IKERNEL.EXE) stays in memory for a few seconds at the end of an install. Wait a few seconds and try again.

  • Use Ctrl/Alt/Del, click Task Manager, then the Processes tab. Look for IKERNEL.EXE. If no setup program is currently running, highlight IKERNEL.EXE and click End Task. Try the setup again.

  • Use Windows Explorer, and remove all files from the C:\TempC:\windows\Temp orC:\WINNT\Temp folder.

  • Use Windows Explorer and open Program Files\Common Files\InstallShield. Remove theEngine folder and then rerun the setup.

  • Core Windows files may be missing or corrupted. Reinstall the latest Internet Explorer and the latest Service Paks.

  • Core Windows file STDOLE.TLB is missing. Copy this file from another computer running the same version of Windows.

 

This Article can be found by searching for:

Keywords: Error Messages: Install

Platforms: Win95, Win98/SE, WinNT, WinMe, Win2K, WinXP, WinVista, Win7

Article#: 671

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Category: Laplink Gold

Last updated on April 6, 2012 with 5272 views


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