How to Restore Default Windows Files

Author Scott M on February 3, 2012 | Print | Bookmark
Last updated on April 6, 2012

Document relates to: Laplink Gold (All Versions)


SUMMARY

I have been instructed to replace or restore a Windows file. How can I do this?


CAUSE

If a program you have installed replaces a core Windows file with an older or modified version, you may experience problems with Laplink products.


SOLUTION

Be sure that the file in question (such as Winsock.dll) does in fact need to be replaced. HINT: if the file has the same creation date as most other files in that same folder, then it is likely the original, Microsoft-supplied version, and does not need to be replaced.

For computers running Windows 95, 98 and ME:

Please see the Microsoft Knowledge Base article Q129605: HOW TO: Extract Original Compressed Windows Files

NOTE: If the System File Checker cannot find the file you want, or if your computer’s operating system was preinstalled (by the OEM), you may change the Restore field to: 

  • C:\Windows\Options\Cabs for Win98 or
  • C:\Windows\Options\Install for Windows ME


For computers running Windows XP:

  1. From the Start button, click Run

  2. In the Open field, type MSCONFIG and press Enter

  3. Click Expand File

  4. In the File to restore field, type the file name.
    NOTE: You will be given the name of the file to replace by another technical document or a support technician. 

  5. In the Restore from field, type C:\Windows\Driver Cache\i386\Driver.cab

  6. In the Save file in field, type C:\Windows\System32.
    NOTE: You may be instructed by another technical document or support technician to restore to C:\Windows. 

  7. Click Expand


This Article can be found by searching for:

Keywords: How To: Windows

Platforms: Win95, Win98/SE, WinNT, WinMe, WinXP

Article#: 296

Was this article helpful?

Yes No

Category: Other

Last updated on April 6, 2012 with 3486 views


Contact & Support Information

Live Chat - Sales, Customer Service & Technical Support:
http://www.laplink.com/contact

Laplink Support Account:
http://www.laplink.com/mysupport/

Customer Service:
1-800-LAPLINK

Forums:
http://forums.laplink.com/