Unable to open window for Remote control [name of Host computer here], Network, TCP/IP: Service not found

Author Lydie B on September 28, 2015 | Print | Bookmark
Last updated on October 2, 2015

Document relates to:   Laplink Gold (All Versions)


SUMMARY

When attempting to remote into the Host PC (target computer) using the '(LAN) Network' or 'Laplink Internet' connection method in Laplink Gold (LLG), the following error occurs:

"Unable to open window for Remote control [name of Host computer here], Network, TCP/IP: Service not found"

 

CAUSE

Various events including but not limited to incorrect task/service chosen, missing or corrupted LLG remote control related components such as video driver or Registry keys, or blocking ports/firewalls/security software can all be contributing factors yielding this error.

 

SOLUTION

Apply the below mentioned steps one at a time before attempting your chosen connection again. If a step fails to resolve the error message, go to the next step. Unless noted otherwise, these steps need to be applied directly on the Host PC (target computer that you are trying to connect to).

 

STEP 1

  1. In the LLG menu, click on Option > Security .

  2. Make sure that the option is either set to Anybody (Public System) or Log-in List Only (Protected System).
    If not, set it to one of these options (if Log-in List..., create a log-in).

  3. In addition, click on the privileges section for your level of access (Public System or Log-in List) and make sure in that location that the task of Remote Desktop is enabled with a checkmark. Confirm with Apply and OK.

     

STEP 2

  1. In the LLG menu, click on Option > Port Setup .

  2. Check in the list that the TCP/IP Network shows as Enabled. If not, enable it. Confirm with Apply and OK.

     

STEP 3

  1. In the LLG menu, under Option > Remote Control Options .

  2. Check your Remote Desktop Host options in the Remote Desktop Host tab and confirm them with Apply and OK.

  3. In the tab's upper section, which shows two checkboxes, ideally just check one of them, Laplink Screen Sharing or Microsoft Remote Desktop (the section below it that shows two radio buttons will then be grayed out).
  4. NOTE: Your selection will depend on the specific Windows version and edition name that you are running on the Host. While Laplink Screen Sharing can be used to connect to all editions of XP, Vista, Windows 7, 8, 8.1 and 10, using Microsoft Remote Desktop is only allowed when connecting to the following Windows editions and when these editions specifically have Remote Desktop Protocol enabled in their system properties (a restriction imposed by Microsoft):

    - Windows 10 Pro & Enterprise

    - Windows 8 Pro & Enterprise

    - Windows 7 Ultimate, Pro & Enterprise

    - Windows Vista Ultimate, Business & Enterprise

    - Windows XP Professional

    Important note for Windows 8.1 and 10 users:

    While Microsoft also natively supports its own Remote Desktop (Remote Desktop Protocol or RDP) on Windows 8.1 and 10, Microsoft Remote Deskop is not available for Windows 8.1 and 10 within Laplink Gold due to a video & graphics driver incompatibility issue, and therefore Laplink Gold users would need to select Laplink Screen Sharing as their remoting option when connecting into a Windows 8.1 or 10 Host PC.

    If within Laplink Gold you choose to select Microsoft Remote Desktop for connections to a compatible Host PC (see list above), make sure that Windows itself on your Host PC allows incoming remote connections.

    To check and set this feature, go to Start > Control Panel > System > Advanced system settings or search for Advanced system settings and click on the resulting link to view the System Properties dialog, select the Remote tab and in the Remote Desktop section, specifically select Allow connections from computers running any version of Remote Desktop. Do not select the Network Level Authentication option. Confirm with Apply and OK.

 

STEP 4

    If you are remoting into a Host PC that has Windows XP or higher operating system installed and after having chosen your connection method in LLG’s Connect Over pane, be sure to specifically select the Remote Desktop task in the Services dialog, not Remote Control. Remote Control is only a legacy option for remoting into a Host with installed Windows 2000 or lower operating system.

 

STEP 5

  1. Open the Windows Device Manager. See Technical Document 359: How to open Windows Device Manager for more information.

  2. In the Display Adapters section, make sure that the Laplink RC Video Driver is showing. If any markers (such as '?' or triangle '!') show by the Laplink RC driver name, try to update the driver (right-click on name entry > Update Driver). If the Laplink RC driver does not show at all, contact Laplink Technical Support.

 

STEP 6

    Open the Windows Task Manager and make sure in the processes tab that the following entries are running in the following configuration:


    LLRCAdmin1.exe

    LLRCServer.exe

    LLRCService.exe          (Note: Process LLRCService.exe must have two instances running.)

 

STEP 7

  1. Open a Windows Explorer window and browse to:

  2. C:\Windows\SysWOW64

     

  3. In the above location, check the size of LLServer.exe via right-click > Properties. Its size should around 1665-1667KB.

     

STEP 8

  1. Open the Windows Registry Editor e.g. using the regedit command.
  2.  

  3. In the Registry Editor, browse to:

  4. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Video

     

  5. In the left-hand pane, under the ...\Video section, you will find a number of keys with long letter/number combinations. Expand each of those keys using the arrow button to the left. Once the subdirectory for each key is visible, click on the first instance of key:

  6. 0000

     

  7. Now in the right-hand pane, find the following entry in the Name column:

  8. InstalledDisplayDrivers

     

  9. Check if in the above location, the following entry is listed in the Data column located all the way to the right:

  10. llrcd

     

    If llrcd is not present, go to the next instance of the 0000 key in the Video keys section. There should be only one single instance of llrcd in all of the Registry; therefore, repeat the above mentioned check for all other instances of the 0000 key in the Video keys section to check if only one or more than one instance of llrcd can be found.

     

STEP 9

    If as per step 6 any of the referenced .exe services are not running or not running in the mentioned configuration, or as per step 7 LLRCServer.exe does not have a size around 1665-1667 KB, or as per step 8 more than one instance of llrcd is found in the Registry, perform a one-time uninstall and reinstall of Laplink's remote control component via the Windows DOS Command Prompt.

     

    TO UNINSTALL:

     

  1. Open a Command Prompt

  2. Note: On XP, you must to be an Administrator user or if on Vista or higher operating system, directly run the Command Prompt as an Administrator (Start/Search cmd > right-click on cmd.exe in Start menu and select Run as administrator).

  3. On a 32-bit operating system: Type cd C:\Program Files\Laplink\LaplinkRC\Driver and press Enter

    On a 64-bit operating system: Type cd C:\Program Files (x86)\Laplink\LaplinkRC\Driver and press Enter

  4. Type Llrcinstall /uninstall and press Enter

 

    TO INSTALL:

     

  1. Open a Command Prompt

  2. Note: On XP, you must to be an Administrator user or if on Vista or higher operating system, directly run the Command Prompt as an Administrator (Start/Search cmd > right-click on cmd.exe in Start menu and select Run as administrator).

  3. On a 32-bit operating system: Type cd C:\Program Files\Laplink\LaplinkRC\Driver and press Enter

    On a 64-bit operating system: Type cd C:\Program Files (x86)\Laplink\LaplinkRC\Driver and press Enter

  4. Type Llrcinstall and press Enter

  5. Reboot the computer for all changes to take effect

 

STEP 10

    If you are connecting to your Host PC using the Laplink Internet connection method but you have the same or another Host PC with LLG available in your local network, try a test connection via the LAN(Network) method instead. In case this connection also fails with the same error message, temporarily disable or, if necessary, uninstall any prominent desktop security software that may be running on the Host (examples: Norton, Kaspersky, McAfee, Avast, Avira, etc.). While disabling or uninstalling, leave the Windows Firewall on for basic protection. Conversely, you may also try disabling the Windows Firewall while leaving your desktop security software active.

     

STEP 11

  1. Directly on your Host PC, type cmd in your Run or Search box to open a Command Prompt.

  2. Type netstat -a -n and press Enter

  3. Now check in the results list if (Microsoft) Remote Desktop and (Laplink) Screen Sharing show as listening ports and are running as services. The assigned port numbers for these two services are and should show in the results list as 3389 and 3390, respectively. If the port number for the service that you used for the connection attempt does not show or neither port number shows, make and save a copy of the Command Prompt result list (directions online) and contact Laplink Technical Support.

 

STEP 12

    Make sure that as appropriate, ports 1547 and 443 are open. The following details apply:


    PORT 1547


    For connections across a local area network (LAN), port 1547 needs to be open on the Transmission Control Protocol/Internet Protocol (TCP/IP) network, in the Windows firewall and on the User Datagram Protocol (UDP) network.


    PORT 443


    For connections via Laplink Internet, port 443 needs to be open for outgoing connections in the Windows firewall and, if present, in any other router/firewalls. Except for very rare cases where a computer/LAN was intentionally configured in a non-standard way, this should already be the case.


    If unsure how to check for open ports in your firewall/router, contact your system administrator or PC/router manufacturer.

     

STEP 13

    If the ports are open as stated above but the error message persists, explicitly allow ports 1547 and 443 as exceptions in your desktop security software. If unsure how to do so, contact your system administrator or security software manufacturer.

     

STEP 14

    Access the PC monitor display settings via the Control Panel or a Start menu search and make sure in that location that the Host PC's main monitor is designated as the primary monitor (labeled '1'). If more than one/any secondary monitors (such as an extension monitor) are attached to the Host PC, make sure that the secondary monitor functions in such role and does not take the role of the primary monitor (configuration in the monitor display settings needs to show order ‘1’ | ‘2’). If the error message persists or the display is in reverse order (‘2’ | ‘1’), temporarily shut down the secondary/extension monitor so that the Host PC only uses the primary monitor.

     

STEP 15

    Check if any remote control software other than Laplink Gold, such as LogMeIn oder PC Anywhere, are installed on the Host PC. If so, minimally end all running processes for these programs via the Task Manager or, if necessary, uninstall them via the Control Panel.

     

STEP 16

    Check if you are running any video players or video-playing programs at the same time that you are attempting the LLG remote connection. If so, temporarily shut down all video players as well as their related processes via the Task Manager (examples: Windows Media Player, VLC, MovieMaker, Real Player, etc.).

     

STEP 17

    If the error message persists after applying all of the above stated troubleshooting steps, contact Laplink Technical Support.

     


This Article can be found by searching for:

Keywords: Connections: Network, Network: TCP/IP not found, Remote control

Platforms: Win95, Win98/SE, WinNT, WinMe, Win2K, WinXP, WinVista, Win7, Win8/8.1, Win10

Article#: 1099

 

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Category: Laplink Gold

Last updated on October 2, 2015 with 2963 views


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